When I run this db2 query:
caller = (Caller)sqlMap.queryForObject("getIPCTData", caller);
I get an error message of "cursor state not valid".
I verified that the stored procedure works correctly when run manually in a db2 screen.
The sql config file is as follows:
<parameterMap id="IPCTParameters" class="com.mbh.esln.sra.domain.Caller">
<parameter property="callerLastName" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="callerFirstName" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="callerPhone" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="callerPhoneExt" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="callerType" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="account" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="memberId" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="memberLastName" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="memberFirstName" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="callDate" mode="INOUT" jdbcType="DECIMAL" javaType="java.lang.String"/>
<parameter property="companyNumber" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="contractNumber" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="okToCall" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="returnCode" mode="INOUT" jdbcType="CHAR" javaType="java.lang.String"/>
<parameter property="transNo" mode="IN" jdbcType="CHAR"/>
<parameter property="subTransNo" mode="IN" jdbcType="DECIMAL"/>
<parameter property="recordSequence" mode="IN" jdbcType="DECIMAL"/>
</parameterMap>
<procedure id="getIPCTData" parameterMap="IPCTParameters" resultClass="com.mbh.esln.sra.domain.Caller">
{call DMCLIB.IPCTSndDtaSRA(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)}
</procedure>
Any ideas why the error message occurs?
Thanks in advance.
Steve Jagels
Sr. Programmer / Analyst
(314)
Jagels, Steve E.'s gravatar image asked Mar 2 2005 at 22:04 in Ibatis-User-Java by Jagels, Steve E.

1 Answers

Looks like you are working on an AS/400. ;-)
This happens when a procedure closes the data set to be returned before iBATIS has read it...there is something you have to do in db2 to make it work, but I do not have it handy.
I will post it tomorrow from work.
Larry
Larry Meadors's gravatar image answered Mar 6 2005 at 23:00 by Larry Meadors

Related Discussions

  • Check If A Connection Is Valid In IBatis in Ibatis-user-java

  • hi my code is like that: public Clip getVideoById(String videoId) throws SQLException{ return (Clip) sqlMapper.queryForObject("getVideoById",videoId); } how can i make sure that the connection to the database is valid and if not to open it? -- View this message in context: http://old.nabble.com/check-if-a-connection-is-valid-in-IBatis-tp26217372p26217372.html Sent from the iBATIS - User - ...

  • What Are The Valid JdbcTypes And Their Default Values. in Ibatis-user-java

  • If I can get a list togeter I will post it to the faq's. I am looking for things like... #termsAccepted:DATE:NO_ENTRY# which does not seem to be working for me. Nathan...

  • Cursor Id Not Valid, Even With Small Batch Size in Mongodb-user

  • I'm sporadically getting 'cursor id not valid at server' errors, even when using a small batch_size. My code (pymongo): codeme_cursor=thiscoll.find({'a.res.z' : ZIPITSELF, 'geo.s' : ''}, {'a.res' : 1}).batch_size(40) for codeme in codeme_cursor:      # do some stuff, avg. time .16 seconds per iteration 40*.16 = 6.4 seconds, so surely the cursor is getting enough action to stay alive...

  • Installing Problems - 'Key Not Valid For Use In Specified State.' in Python

  • I am having trouble installing Python on my Windows 7 (x64) Laptop. The MSI file for Python 3.4.1 that I have downloaded got to the set up page containing 'Please wait while the Installer installs Python 3.4.1' and asks for administrator permission to continue the installation. After I give administrator permission to continue with the install, it gives me the error pop up 'Key not valid for use in...

  • [mongodb-user] [pymongo] Cursor Id '239432858681488351' Not Valid At Server in Mongodb-user

  • -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 How should I value the error Traceback (most recent call last):   File "../../bin/py", line 50, in     execfile(__file__)   File "enumerate_topics.py", line 7, in     for num, row in enumerate(db.topics.find()):   File "/home/ajung/occ/eggs/pymongo-1.5.2-py2.6-linux-x86_64.egg/pymongo/cursor.py", line 503, in next     if len(self...

  • Supplied Argument Is Not A Valid MySQL Result in Php-general

  • Warning: Supplied argument is not a valid MySQL result resource in /home/sites/projects.heathermccullough.com/web/copeland/product.php on line 61 Here is the code, I fixed it once, and I cant figure out why it keeps returning. if ($submit) { $sql = ("SELECT * FROM store WHERE state = '$State' AND groups = '$group_id'"); $result = mysql_query($sql); if(mysql_num_rows($result) > 0) { < - ...

  • Not A Valid Pdf in Pdfbox-users

  • I have a customer who tried to upload a PDF to my site. They got an error from my app stating 'not a valid pdf'. I ran the following locally with the same PDF my customer tried to upload. C:\Documents and Settings\nbdvf7d\Desktop\MEE_VRS\perf\sept 15\MerchantExplorer\ WebContent\WEB-INF\lib>java org.pdfbox.ExtractText c:\2800674852 POD.pdf Exception in thread "main" java.lang.NullPointerException...

  • Not Valid XHTML in Ubuntu-users

  • www.ubuntulinux.org has nice XTHML icon at the bottom of page but W3C said it's not vaid XHTML : http://validator.w3.org/check?uri=http%3A%2F%2Fwww.ubuntulinux.org%2Fwiki%2F UbuntuBootupHowto This page is not Valid XHTML 1.0 Transitional! Line 400, column 4: end tag for "ul" which is not finished ... BTW: Ubuntu rocks! But I?am a?litle sicked about curent mono (www.go-mono.com) state at Ubuntu...

  • ISO File Not Valid? in Ubuntu-users

  • Hi there. I downloaded several Ubuntu CD images. They open in the archive manager OK, and seem to have all their bits. When I move one into the CD/DVD creator and say "write to disk", it asks me whether I want to create from image or put the file on the disk. I click "Create from image" and it tells me: No such file or directory The file 'ubuntu-6.06-server-i386.iso' is not a valid disc image...

  • Imagesx(): Supplied Argument Is Not A Valid Image Resource in Php-general

  • I am running on Windows 200, PHP 4.3.9 I have my extensions directory set. ;Windows Extensions ;Note that MySQL and ODBC support is now built in, so no dll is needed for it. ; extension=php_gd2.dll extension=php_mime_magic.dll extension=php_pdf.dll extension=php_zip.dll But I get this error: imagesx(): supplied argument is not a valid Image resource when I try to get the information...

  • C Client "0" State? in Zookeeper-user

  • Hi everyone in the c client api: Is it normal for zoo_state() to return zero (not one of the valid state consts) when it is handling socket errors? In the C Code, handle_error(), which handles socket errors, sets the zh->state to zero, ================== if (!is_unrecoverable(zh)) zh->state = 0; ================== If the handle is recoverable, why is the state set to zero, which...

  • Not A Valid Tar File in Mysql-general

  • I have downloaded the mysql-3_22_32_tar.tar file twice and cannot get it to expand with PowerZip on my Windows machine (all other .tar files do work with this installation) or on the Unix server at my client site. In Unix, I Telnet in and use the following command: tar x mysql-3_22_32_tar.tar which sends Telnet into LaLa land. I doublechecked and my FTP program is sending it to the Unix server...

  • Specified Cast Is Not Valid? in Ibatis-user-cs

  • Hello ! Iam using IBATIS and creating very very simple example, facing the following error: Exception Details: System.InvalidCastException: Specified cast is not valid. Source Error: Line 31: void Load_List() Line 32: { Line 33: DataGrid1.DataSource=Mapper.Instance().QueryForList("Select",null); Line 34: DataGrid1.DataBind(); Line 35: any ideas why this thing happened? Take ...

  • Valid PDF Not Parsing: NoSuchElementException in Pdfbox-users

  • Hi, I have several PDFs that seem to have no issue being opened by Adobe Reader (8.1) and Acrobat 9. I am using Tika 0.4 (and testing same issue with tika 0.5 as it fails in both versions). I have tracked the issue down to PDFBox as follows. When extracting in PDFBox 0.7.3 (and also with 0.8.0-incubating), I get the following(...0.8.0-incubating): Exception in thread "main" org.apache.pdfbox....

  • [2.0-java] Not Valid YAML in Play-framework

  • Hello, I have a initial-data.yml file that i want to use on start of my application like this : public class Global extends GlobalSettings { public void onStart(Application app) { InitialData.insert(app); } static class InitialData { public static void insert(Application app){ if(Ebean.find(User.class).findRowCount() == 0) { Map all = (Map)Yaml.load...

  • [mongodb-user] Install Problem - 'Key Not Valid For Use In Specified State' in Mongodb-user

  • When triying to install 2.6.5 2008R2Plus (64 bit) the Setup quickly with the message 'Key not valid for use in specified state'. I have no clue what is going wrong, and appreciate help. Best regards, Heinz You received this message because you are subscribed to the Google Groups "mongodb-user" group. For other MongoDB technical support options, see: http://www.mongodb.org/about/support...

  • Java.lang.IllegalStateException: Calling [asyncComplete()] Is Not Valid For A Request With Async State [COMPLETING] in Tomcat-users

  • Hi Folks, I am using Tomcat 7.0.42, in embedded mode, using NIO connector. Running on a linux box. I use request.startAsync() to create an AsyncContext. And call complete() Any idea why am i getting this exception? Thanks, Vicky...

  • Mysql Not Valid Resource in Php-db

  • Hi all, I have a problem with mysql: this code produce a not valid mysq resource. $sql="select distinct des_riga, count ( des_riga ) as freq from k_riga where id_tabella=" . $id_tabella . " and id_colonna=" . $id_colonna . " group by des_riga order by des_riga"; $query=mysql_query ($sql, $connessione); $id_tabella, $id_colonna and $connessione has the correct value... The same query runs...

  • Not A Valid BCFile Exception in Hadoop-hdfs-user

  • Hi, I am using TFile for storing the Key, Value pairs. After writing, when I open it back for reading, I am getting the following error. Exception in thread "main" java.io.IOException: Not a valid BCFile. at org.apache.hadoop.io.file.tfile.BCFile$Magic.readAndVerify(BCFile.java:923) at org.apache.hadoop.io.file.tfile.BCFile$Reader.(BCFile.java:625) at org.apache.hadoop.io.file.tfile....

  • Valid Wsdl Not Loading in Jmeter-user

  • Hi, I am a new-comer to testing webservices with JMeter. I have a WSDL that is valid (see below) and recongised as such when I load it through your WebService(SOAP)Request gui. I have also verified it by loading it in a browser as per the user manual: http://jakarta.apache.org/jmeter/usermanual/build-ws-test-plan.html However, the "Web methods" drop down is not populated as expected. There ...

  • Not Valid Tomcat Installation in Tomcat-users

  • I install Tomcat 6.0.18 in c:\tomcat. When add the new server Eclipse writes that tomcat install directory is not correct. It does not point to valid Tomcat installation. What should I do ?...